Twitter Facebook Google Plus LinkedIn Siguenos en Youtube Follow Me on Pinterest Email
0


Estos son los pasos que se deben seguir para solucionar problemas en una red.

DOCUMENTAR LA RED

Antes que nada es importante, documentar toda la red, utilizar todos los comandos y hacer las verificaciones, para luego anotarla y saber que posibles cambios se puedan presentar. Anote todo y utilice todo lo que pueda los comandos show para verificar direccionamiento, conectividad, etc.
Al documentar la red, puede ser necesario recopilar información directamente de routers y switches.

LOS COMANDOS
Telnet, show cdp neighbors detail y show ip route

- El comando ping, que se usa para probar la conectividad con los dispositivos vecinos antes de conectarse a ellos. Al hacer ping a otras PC en la red también se inicia el proceso de descubrimiento automático de direcciones MAC. 
-  El comando telnet, que se usa para conectarse de manera remota a un dispositivo para obtener acceso a la información de configuración.
-  El comando show ip interface brief, que se usa para mostrar el estado activo o no activo y la dirección IP de todas las interfaces en un dispositivo.
-  El comando show ip route, que se usa para mostrar la tabla de enrutamiento en un router para conocer los vecinos conectados directamente, más dispositivos remotos (a través de las rutas conocidas) y los protocolos de enrutamiento que se han configurado.
-  El comando show cdp neighbor detail, que se usa para obtener información detallada acerca de los dispositivos vecinos Cisco conectados en forma directa.

DATOS IMPORTANTES
TABLA 1
Nombre dispositivo, nombre interfaces, mac, ip, protocolos
TABLA 2 Nombre dispositivo, OS, ip, gateway, dns, wins, aplicativos, voip?
Puertos de dispositivos de red que se conectan a otros dispositivos de red
Servidores
Usuarios clave

Tipo de dispositivo
Modelo y fabricante
Versión del sistema operativo
Tipo de cable e identificador
Especificación del cable
Tipo de conector
Extremos de cableado

Identificadores de dispositivos
Subred y dirección IP
Identificadores de interfaz
Tipo de conexión
DLCI para circuitos virtuales
VPN de sitio a sitio
Protocolos de enrutamiento
Rutas estáticas
Protocolos de enlace de datos
Tecnologías WAN usadas



DESCUBRIR PERSONALIDAD DE LA RED

- Utilice el comando Show para recopilar todas las estadísticas.
¿Cómo funciona la red durante un día normal o promedio?
¿Dónde se encuentran las áreas utilizadas en exceso y las áreas utilizadas insuficientemente?
¿Dónde ocurre la mayoría de los errores?
¿Qué niveles hay que establecer para los dispositivos que deben supervisarse?
¿La red puede proporcionar las políticas identificadas?

MEDICIÓN DE DATOS

- Utilice el comando Show para recopilar todas las estadísticas, luego documéntelo, y luego compare, para verificar cambios en la red.

image


IDENTIFICAR EN QUE CAPA DEL MODELO OSI ESTA EL PROBLEMA

El modelo de referencia OSI describe cómo la información de una aplicación de software en una computadora se desplaza a través de una red a una aplicación de software en otra computadora.

Las capas inferiores (1 a 4) del modelo OSI manejan los problemas relacionados con el transporte de datos. Las capas 3 y 4 se implementan, generalmente, sólo en software. La capa física (capa 1) y la capa de enlace de datos (capa 2) se implementan en el hardware y el software.

- Separar la configuración en varias capas del modelo OSI y TCP-IP
- Describa a que dispositivos le pertenecen.

PROCEDIMIENTOS GENERALES RESOLUCIÓN DE PROBLEMAS

1.  Recopilación de síntomas.
componentes de la red se vieron afectados y cómo cambió la funcionalidad de la red en comparación con la línea de base.  Mirar síntomas, como mensajes de consola, sector que no funciona.
2.   Aislamiento del problema.
Identifico en que capas surgió, cual es la causa y lo documenta.
3.   Corrección del problema: 
Implementación, prueba y documentación de una solución, por si debe volver a dejar todo como estaba.

METODOS DE RESOLUCIÓN
- Utilice el comando Show para recopilar todas las estadísticas.
1.  Ascendente: Desde la física a la lógica, especial si sospecha si hay problemas físicos.
Requiere revisar cada dispositivo.
2. Descendente:  Se empieza analizando desde las aplicaciones, la configuración.
Requiere revisar cada aplicación.
3. Divide y vencerás.
- Se comienza por recopilar la experiencia del usuario acerca del problema, documentar los síntomas.
- Realizar una suposición informada sobre en cuál capa de OSI se comenzará la investigación. 
- Se supone que las capas debajo de esa están funcionando y se sigue con superiores.
- Si una capa no funciona, es necesario desplazarse en sentido descendente 
Ejemplo 1
Si no pueden acceder al servidor Web y hacer ping al servidor, el problema está por encima de capa 3. Si no se puede hacer ping al servidor, se sabe que el problema está en una capa de OSI inferior.

RECOPILACIÓN DE SINTOMAS

image

¿Que no funciona?, ¿Cuando?, ¿Como se produjo? ¿Sucedió algo inusual? ¿Secuencia de eventos?
1. Análisis de los síntomas actuales: se analizan los síntomas recopilados de los informes de problemas, usuarios o sistemas finales afectados.
2. Determinación de propiedad: si el problema se encuentra dentro de su sistema, puede pasar a la etapa siguiente. 
3. Reducción del alcance: se debe determinar si el problema está en la capa núcleo, de distribución o de acceso de la red. En la capa identificada, analice los síntomas.
4. Recopilación de síntomas de dispositivos sospechosos: mediante un enfoque de resolución de problemas en capas, se recopilan síntomas del hardware y software de los dispositivos sospechosos.  5. Documentación de síntomas: a veces, el problema puede resolverse utilizando los síntomas documentados.

HERRAMIENTAS
-  NMS:  CiscoView, HP Openview, Solar Winds y What's Up Gold.
Incluyen herramientas de supervisión, configuración y administración de fallas de los dispositivos.
-  BASE DE CONOCIMIENTOS:  Documentación en Cisco.com en Tools and resources
-  LINEA BASE:  aplicaciones de software SolarWinds LANsurveyor y CyberGauge.
Pueden servir como ayuda para dibujar diagramas de red, mantener actualizada la documentación de software y hardware de la red.
- ANALISADOR DE PROTOCOLOS: Wireshark.
Un analizador de protocolo decodifica las distintas capas de protocolo en una trama registrada y presenta esta información en un formato relativamente fácil de usar.

TOPOLOGÍA WAN
1.  Establezca las características del trafico, el tipo de aplicaciones. VoIP, P2P
2.  Determine cuales son los puntos finales de la LAN.
3. Determine el patrón de diseño para los enlaces.  Si es estrella, jerárquica, malla, etc.

TECNOLOGÍAS DE CONEXIÓN WAN
image

Una WAN privada típica utiliza una combinación de tecnologías que se eligen, en general, según el tipo y el volumen del tráfico. ISDN, DSL, Frame Relay o las líneas arrendadas se utilizan para conectar sucursales individuales en una sola área. Frame Relay, ATM o las líneas arrendadas se utilizan para conectar áreas externas nuevamente al backbone. ATM o las líneas arrendadas forman el backbone de la WAN.

RESOLUCIÓN PROBLEMAS WAN
- Host de PC individual: una gran cantidad de aplicaciones de usuario abiertas en la PC al mismo tiempo puede ser la causa de la lentitud que se le atribuye a la red. Las herramientas como el Administrador de tareas en una PC con Windows pueden ser útiles para determinar la utilización de CPU.
- LAN : si el cliente tiene software de supervisión de redes en su LAN, el administrador de red debe poder indicar si el ancho de banda de la LAN alcanza con frecuencia una utilización del 100%. Éste es un problema que la empresa cliente debería resolver internamente. Por este motivo es tan importante establecer una línea de base de red y realizar una supervisión constante.
- Enlace desde el punto extremo de la red del usuario hasta el punto extremo del ISP: pruebe el enlace desde el router extremo del cliente hasta el router extremo del ISP pidiéndole al cliente que se conecte a su router y envíe cien pings de 1500 bytes (pings de esfuerzo) a la dirección IP del router extremo del ISP.
Backbone del ISP: el representante de servicio al cliente del ISP puede ejecutar pings de esfuerzo desde el router extremo del ISP hasta el router extremo del cliente.
Acceso al servidor: en algunos casos, la lentitud que se atribuye a la red puede estar causada por la congestión del servidor. Este problema es el más difícil de diagnosticar y debe ser la última opción que se considera, luego de que todas las demás opciones se hayan descartado.

Síntomas de problemas en la capa física y soluciones.
- Rendimiento menos a la línea de base: Por sobrecarga o falta de potencia en servidores.
- Pérdida de conectividad: Mirarlo por hacer ping.
- Alto nivel de colisión.
- Cuellos de botella o congestión en la red: Se puede solucionar cuando un router sepa re-direccionar trafico.
- Altos porcentajes de utilización de CPU.
- Mensajes de error de consola.
- Ruido (EMI)
- Superación de los limites del diseño.
- Errores de configuración de la interfaz.
Compruebe que todos los puertos de switch estén configurados en la VLAN correcta y que las configuraciones de spanning-tree, velocidad y dúplex sean correctas. Confirme que los puertos e interfaces activos no estén desactivados.
- Las tarjetas de interfaz de red (NIC) con fallas pueden causar errores de transmisión de red debido a colisiones tardías, tramas cortas y jabber. El jabber se define en general como la condición en la cual un dispositivo de red transmite continuamente datos sin sentido y al azar a través de la red. Otras causas posibles del jabber son los archivos de los controladores de NIC dañados o fallados, el cableado incorrecto o los problemas de conexión a tierra.
- Fallas de cableado
Muchos problemas pueden corregirse, simplemente, al reacomodar los cables que se han desconectado parcialmente. Cuando se realiza una inspección física, deben buscarse cables dañados, tipos incorrectos de cables y RJ-45 mal engarzados. Los problemas con el cable coaxial a menudo ocurren en los conectores.
Use un probador de cables con los jacks de pared sospechosos para asegurarse de que el jack esté conectado correctamente.
Puede ser necesario un cable cruzado para las conexiones directas entre algunos dispositivos. Compruebe que el cable esté conectado correctamente. Por ejemplo, en la figura, el medidor Fluke CableIQ ha detectado que, aunque un cable era correcto para Fast Ethernet, no admitía 1000BASE-T porque los cables 7 y 8 no estaban conectados adecuadamente. Estos cables no se necesitan para Fast Ethernet, pero sí se necesitan en Gigabit Ethernet.
- Utilice el comando Show para recopilar todas las estadísticas.

CAUSAS Y RESOLUCIÓN DE PROBLEMAS CAPA ENLACE DE DATOS
Las tramas toman rutas subóptimas debido a una topología de spanning-tree mal diseñada. Por ello la red podría experimentar uso en exceso del ancho de banda.
- Algunas tramas se descartan, que se revelan con un ping extendido, o por mensajes de consola.
- Los OS utilizar mucho los broadcasts; aveces por malas configuraciones.
- Pueden haber problemas de encapsulación, cuando se configuran diferente en ambos extremos.
- En Frame Relay, PPP, se les debe asignar a las tramas una dirección de destino de capa 2.
- Mirar si dispositivos se configuraron para no responder a solicitudes ARP y ARP inverso.
- Un error de entramado ocurre cuando una trama no termina en un límite de byte de 8 bits, y esto hace que receptor tenga problemas para determinar donde termina o empieza una trama.  Esto se produce por el ruido.
- STP resuelve problemas de redundancia, y los problemas radican en el reenvío de bucles cuando no se bloquen puertos en topología redundantes, y esto genera congestiones.
-  Cuando un enlace de puerto de switch se activa o desactiva, ocurre cambio de topología y de estado de STP.
- Verifique que no halla error en la asignación de direcciones.
- Verificar que se usa la encapsulación adecuada en los dos extremos mediante el comando Show interfaces serial.
- En PPP confirmar que las negociaciones del control de enlace (LCP) se realizaron correctamente.  Verificar la conexión física entre la CSU/unidad de servicios de datos (DSU) y el router.
- Utilizar el comando show frame-relay lmi para verificar que el router y el proveedor de Frame Relay estén intercambiando información LMI de manera adecuada.
- Comando show frame-relay pvc en Router verifica que el estado PVC es activo. 
-  Utilizar el comando show interfaces serial para verificar que la encapsulación de Frame Relay coincida en los dos routers.
- El show interface serial /  nos muestra el tipo de encapsulación HLDC o framerelay.

BUCLES STP
- Para verificar el funcionamiento de STP, use el comando show spanning-tree en cada switch. Si descubre que STP no está funcionando, puede activarlo mediante el comando spanning-tree vlan ID.
- Mensajes Syslog que indican un reaprendizaje constante de direcciones o mensajes inestables de direcciones MAC.
- La prioridad más alta es detener el bucle y restaurar el funcionamiento de la red. Para detener el bucle, debe conocer qué puertos están involucrados. Observe los puertos con el nivel de utilización de enlaces más elevado (paquetes por segundo), El comando show interface muestra la utilización de cada interfaz. Asegúrese de registrar esta información.
- Desactive o desconecte los puertos comprometidos, uno por vez. Luego de deshabilitar o desconectar cada puerto, verifique si la utilización del backplane del switch volvió al nivel normal.
- Mirar si el switch conoce la raiz STP correcta, si se reciben BPDU regularmente.


RESOLUCIÓN PROBLEMAS CAPA 3

- Buscar cambios de topología,
- Problemas de conectividad,
- Relación con vecinos de enrutamiento.
- Comprobar problemas de tabla de enrutamiento.

RESOLUCIÓN DE PROBLEMAS ACL

- Selección del flujo de tráfico: Para que funcione de manera adecuada, una ACL debe aplicarse a la interfaz correcta y debe seleccionarse la dirección correcta del tráfico.
- Orden de los elementos de control de acceso:  Los elementos de una ACL deben ordenarse de los más específicos a los generales.
- Deny all implícito: En una situación donde no se requiere un alto nivel de seguridad en la ACL, no incluir este elemento de control de acceso implícito puede ser la causa de una configuración incorrecta de la ACL.
- Direcciones y máscaras wildcard: Si el router ejecuta ACL y NAT, el orden en el cual se aplica cada una de estas tecnologías a un flujo de tráfico es importante.
- Las máscaras wildcard complejas proporcionan mejoras notables en la eficacia, pero son más propensas a errores de configuración. Un ejemplo de máscara wildcard compleja es utilizar la dirección 10.0.32.0 y la máscara wildcard 0.0.32.15 para seleccionar las primeras 15 direcciones host en la red 10.0.0.0 o en la red 10.0.32.0.
- Selección del protocolo de la capa de transporte.  TCP, UDP
- Puertos de origen y destino: El control adecuado del tráfico entre dos hosts requiere elementos de control de acceso simétrico para las ACL de entrada y de salida.
- La palabra clave established aumenta la seguridad provista por una ACL. Sin embargo, si se aplica la palabra clave a una ACL saliente, pueden obtenerse resultados inesperados.
- Un comando útil para observar el funcionamiento de la ACL es la palabra clave log en las entradas de ACL. Esta palabra clave le indica al router que coloque una entrada en el registro del sistema cuando hay una coincidencia con esa condición de entrada. El evento registrado incluye detalles del paquete que coincidió con el elemento de la ACL.

PROBLEMAS NAT

El mayor problema de las tecnologías de NAT es la interoperatividad con otras tecnologías de red, en especial con aquellas que contienen o derivan información de direccionamiento de red del host en el paquete. Problemas con el DHCP, DNS, SNMP.
Protocolos de tunneling y encriptación: los protocolos de tunneling y encriptación a menudo requieren que el tráfico se origine desde un puerto UDP o TCP específico o que se use un protocolo en la capa de transporte que la NAT no puede procesar. Por ejemplo, la NAT no puede procesar los protocolos de tunneling IPsec y los protocolos de encapsulación de enrutamiento genéricos que usan las implementaciones de VPN.

ERRORES CAPAS SUPERIORES.
- Aquí se encuentran los problemas relacionados con los protocolos, como el ftp, tftp, pop, nfs, snmp, etc. También con sus respectivos puertos.
- Rendimiento lento de aplicaciones.
- Una solución es hacer ping al gateway.
- Verificar conectividad en extremos.
- Show access-list
- Show ip nat translations.
- Clear access-list counter y clear ip nat translation.
- Recuerde hacer copias de seguridad.

0

Del canal en Youtube de IpGuerrero, he logrado encontrar una serie de vídeo tutoriales muy completos para entender el funcionamiento de webmin para linux.

 

En un anterior articulo habíamos publicado una buena cantidad de manuales para squid, en esta ocasión les comparto unos vídeo tutoriales que nos explican mucho mas sencillamente como configurarlos.

 

Instalación con WebMin

FreeBSD es un firewall bajo linux que podemos instalar para proteger nuestra red. No encontré mucho material, aunque su configuración es realmente fácil.  Claro esta que el manual más completo y detallado lo encontraremos en la propia página del desarrollador.  http://www.freebsd.org/doc/es/books/handbook/index.html

 

 

 

 

Para quienes buscan un servidor proxy para su red, les recomiendo el squid proxy, les adjunto una serie de manuales con todo lo que necesitan para instalarlo en ubuntu. También encontrarán unos manuales para instalarlo junto con Webmin y poderlo configurar desde una interfaz web.

 

CONFIGURACIÓN EN UBUNTU

 

 

CONFIGURACIÓN CON WEBMIN

 

 

 

 

 

CONFIGURACIONES AVANZADAS.

 

 

 

CONFIGURACIONES BÁSICAS

 

 

 

 

 

INSTALACIÓN EN CENTOS.

http://elmampano.wordpress.com/2011/06/17/manual-de-un-servidor-proxy-squid-en-centos-5-4/

 

CONFIGURACIONES COMPLEMENTARIAS

 

 

VIDEO TUTORIALES

 

Para los que están siguiendo el currículo de cisco CCNA Exploration, esta es la solución a la actividad 7.4.1 En el cual nos plantea como objetivo lo siguiente.

 Preparar la red
 Realizar las configuraciones básicas del router
 Configurar un servidor de DHCP del IOS de Cisco
 Configurar el enrutamiento estático y predeterminado
 Configurar NAT estática.

image

TAREA 1 CONFIGURACIÓN BÁSICA.

Router#erase startup-config
Router#configure terminal
Router(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config-line)#enable password cisco
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#logging synchronous
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#logging synchronous
R1(config)#banner login "Personal autorizado"
R1(config)#banner motd "Revision 1"

Luego debe de ingresar el siguiente direccionamiento ip.

image

Al finalizar esta actividad debe de aparecer un 50% de la actividad completa.


Tarea 2: Configurar un servidor de DHCP del IOS de Cisco

R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
R1(config)#ip dhcp excluded-address 192.168.11.1 192.168.11.10

Paso 2. Configurar el pool.
R1(config)#ip dhcp pool R1Fa0
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#dns-server 192.168.11.5
R1(dhcp-config)#default-router 192.168.10.1
R1(config)#ip dhcp pool R1Fa1
R1(dhcp-config)#network 192.168.11.0 255.255.255.0
R1(dhcp-config)#dns-server 192.168.11.5
R1(dhcp-config)#default-router 192.168.11.1

Paso 3. Verificar la configuración del DHCP.
R1#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Dirección de Hardware
192.168.10.11 0007.EC66.8752 – Automatic
192.168.11.11 00E0.F724.8EDA – Automatic

Tarea 3: Configurar el enrutamiento estático y predeterminado

ISP(config)#ip route 209.165.200.240 255.255.255.240 serial 0/0/1


Tarea 4: Configurar NAT estática

R2(config)#ip route 0.0.0.0 0.0.0.0 209.165.200.226
R2(config)#router ospf 1
R2(config-router)#default-information originate


Tarea 5: Configurar NAT dinámica con un conjunto de direcciones

R2(config)#ip nat inside source static 192.168.20.254 209.165.200.254
R2(config)#interface serial 0/0/1
R2(config-if)#ip nat outside
R2(config-if)#interface fa0/0
R2(config-if)#ip nat inside
R2(config)#ip nat pool MY-NAT-POOL 209.165.200.241 209.165.200.246 netmask 255.255.255.248
R2(config)#ip access-list extended NAT
R2(config-std-nacl)#permit ip 192.168.10.0 0.0.0.255 any
R2(config-std-nacl)#permit ip 192.168.11.0 0.0.0.255 any
R2(config)#ip nat inside source list NAT pool MY-NAT-POOL
R2(config)#interface serial 0/0/0
R2(config-if)#ip nat inside
R2#show ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 209.165.200.241 192.168.10.11 --- ---
--- 209.165.200.242 192.168.11.11 --- ---
--- 209.165.200.254 192.168.20.254 --- ---


Tarea 6: Configurar NAT con sobrecarga

R2(config)#no ip nat pool MY-NAT-POOL 209.165.200.241 209.165.200.246 netmask 255.255.255.248
R2(config)#no ip nat inside source list NAT pool MY-NAT-POOL
R2(config)#ip nat inside source list NAT interface S0/0/1 overload
R2#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 209.165.200.225:3 192.168.10.11:3 209.165.200.226:3 209.165.200.226:3
icmp 209.165.200.225:1024192.168.11.11:3 209.165.200.226:3 209.165.200.226:1024 ---

0

Aquí les dejo unos manuales con los que se podrán guiar para crear sus propios formularios.

 

Del sitio http://trucosdeexcel.com/ extraje el siguiente contenido.

0

Los macros, los filtros y las tablas dinámicas son las funciones más avanzadas del Excel. Los siguientes manuales explican muy bien el tema.

0
En estos manuales encontraran todo lo que necesitan para entender como funcionan las funciones.




LISTA DE FUNCIONES CON EJEMPLOS


La siguiente lista de funciones han sido tomadas del siguiente sitio web.
https://sites.google.com/site/misitioexcel/Excel/lista-de-funciones-1
FUNCIONES MATEMATICAS

FUNCIONES BASES DE DATOS


FUNCIONES DE FECHA Y HORA


FUNCIONES DE INFORMACIÓN

FUNCIONES DE TEXTO

FUNCIONES ESTADISTICAS

FUNCIONES LOGICAS

FUNCIONES DE BUS


COMPLETA LISTA DE FUNCIONES


Del sitio de Microsoft hemos tomado las siguientes referencias.
http://office.microsoft.com/es-es/excel-help/lista-de-funciones-de-hoja-de-calculo-por-categoria-HP010079186.aspx



0

Aquí les dejo una lista de manuales en Excel para todos los niveles.

0

Continuamos con los vídeos de Excel, en esta ocasión les traigo varios tutoriales muy completos.

 

 

 

 

 

De las aplicaciones más usadas en las empresas es el Excel.  Hay muchas alternativas, pero la más fácil de usar y la más completa es en definitiva el Excel. Aquí les dejo algunas series de tutoriales para que se conviertan en expertos.  Solo deben de ir al YouTube de cada vídeo y completar toda la serie que le corresponde.